Opened

Navigation stopped working in 0.9.5

apaulin commented edited

Hi,

I just upgraded to 0.9.5 (very nice work on the stuff included BTW and in the updates to the documentation) and a navigation link on my code stopped working and I am not really sure why, I have read the release notes and do not see anything related to this.

Have the following code to generate table rows with a button, I have a "route" to a different page in the button which I set with the 'To' attribute:

<TableRow>
			<TableRowCell>@table.TableName</TableRowCell>
			<TableRowCell>@table.TableDescription</TableRowCell>
			<AuthorizeView Roles="Developer">
					<TableRowCell TextAlignment="TextAlignment.Center">@table.UserCanAccess</TableRowCell>
					<TableRowCell>@table.LastPromoted</TableRowCell>
					<TableRowCell TextAlignment="TextAlignment.Center">@table.Access</TableRowCell>
			</AuthorizeView>
			<TableRowCell TextAlignment="TextAlignment.Center">
					<Dropdown Direction="Direction.Start">
							<DropdownToggle Color="Color.None" ToggleIconVisible="false">
									<Icon Name="IconName.MoreHorizontal" />
							</DropdownToggle>
							<DropdownMenu>
									<DropdownItem>											
											<Button Type="ButtonType.Link"
															Color="Color.None"
															Border="Border.White"
															To="@($"{PageNameParam}/{(table.TableName).Replace("_", string.Empty)}/{true}?Access={table.Access}")">
													Open
											</Button>
									</DropdownItem>
							</DropdownMenu>
					</Dropdown>
			</TableRowCell>
</TableRow>

I had even tried using a Link, replacing the Button element above with the following;

<Blazorise.Link To="@($"/{(table.TableName).Replace("_", string.Empty)}/?Access=")">
Open
</Blazorise.Link>

Both worked before I upgraded to 0.9.5, when I clicked on the button or the link the appropriate page got opened but after I upgraded to 0.9.5 the code stopped working, it almost looks like the hyperlinks were disabled somehow. Weird think is that if I inspect the page (opening the DevTools) and click on the link href a new browser tab gets opened with the appropriate blazor page loaded:

<div class="dropdown-menu show"><!--!-->
		<a class="dropdown-item"><!--!-->
			<a id="0HMDH6NJ39UAR" class="btn border border-white" role="button" href="MasterInfo/edbpecinfo/True?Access=RW" _bl_c4064e9a-52b3-436d-8948-747165c10d1b="" data-ripplet="">
					<!--!-->
					Open
			</a>
	</a>
</div>

Any idea why this may have stopped working? Were there any changes made on the way the routing is handled for these elements maybe?

Thanks!

David-Moreira commented

Hello,
Blazorise.Link should be working as before.
We use Blazorise.Link ourselves in our Demo / Documentation projects. We are not aware of any changes that could be provoking that behaviour. Can you provide us with a repository showcasing the problem, so it's easier for us to troubleshoot?

Thank you!

mladenmacanovic commented

I can see that you have a element inside of another a element. Maybe that is the reason for it to not work?

Want to comment on this issue? Log in and write your comment.
Asignee
No assignee
Labels
No Labels